Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-01-2003, 10:23 PM
Posts: n/a
Question hydro-pneumatic pump

The hydrualic pump on the front of the 84 500sel seems to be leaking from the bottom when the motor is running. This pump feeds the strut system to all four wheels. Does anyone know if there is a rebuild kit or an o-ring that could be replaced rather than installing a new pump? Also, is there some way to find out if this pump is the same as the pump used on the 560? I'm tempted to take it off and see, but I hate to take the chance of making it worse without a backup plan.
Reply With Quote
Old 05-03-2003, 09:41 PM
Registered User
Join Date: Jul 2000
Posts: 638
Hydropump kit

a seal kit for the hydropnuematic oil pump is available from th eDealer
Reply With Quote
Old 05-04-2003, 08:55 PM
Posts: n/a
seal kit

thanx for the info, I will try calling this week. So far the dealer hasn't seemed very informative about the euro models. I'll post a reply when (or if) I get it repaired.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:39 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page