Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-02-2003, 11:04 AM
Registered User
 
Join Date: Apr 2003
Posts: 10
clicking noise from engine

got my 99 e430 about six months ago. since then, a clikcing noise has been gradually getting louder. it's coming directly from the engine block and sounds like, well it's similar to whata diesel engine sounds like. what is this and what do i need to do to fix this?
Reply With Quote
  #2  
Old 05-02-2003, 06:37 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
Could be a sticking valve, but you might want to take this to a dealer or an independent mechanic that specializes in Mercedes cars.

Where are you located? I can point out some good shops in Southern California.

There are a lot of shops mentioned in the Good Shops forum...
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #3  
Old 05-05-2003, 03:01 PM
Registered User
 
Join Date: Apr 2003
Posts: 10
thanks,
im in norcal.

i found that there is actually two areas where the noise is coming from. one is a small device, about the size of a fist with the letters MOT on it. i think its something called a purge valve. i messed around with it a bit and the noise goes away, but grtadually come back. from what i gather, i need to replace the mount. will do this week.

as for the other source is coming directly from the engine. if its a sticking valve, what are some things i can do myself? can i use some sort of detergent type cleaner? (of course i will have it checked out, but if i can save a buck.....)
Reply With Quote
  #4  
Old 05-05-2003, 03:06 PM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
I don't think it would hurt to run a few tankfulls with Techron in it back-to-back-to-back.

I don't know if it'll cure the problem, or not, if it is a sticking valve.

There are a good number of members here that are in Nor. Cal.

Try the search function in the "good shops" sub-forum and see what comes up.

Sticking valve issues have come up for discussion from time-to-time, too. If you experiment with the search function, some of the good threads might come up.

Good luck.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 03:50 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page