Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2000, 12:46 PM
Registered User
 
Join Date: Nov 1999
Location: Germany
Posts: 63
Scenario: 200 mile round-trip (each way).

Weather: Winter 28-35 degrees F.

Climate control system: works great each way for first 30-40 miles, then blows super hot air from all vents for remainder of trip.

Result: Driving with front and rear windows down in dead of winter to keep interior below 90 degrees F.

Switchology: Doesn't matter, any setting produces same results. Have pulled and inspected solenoid valve inside mono valve multiple times, no tears in rubber, looks OK (new one on order). A/C switch assembly pulled, cleaned, checked. Works perfectly at dealer, he swears all is well.

Requirement: Any and all advise on how to fix climate control. Has been recurring problem over last year, no one can fix. car.

JoeB

Reply With Quote
  #2  
Old 02-22-2000, 09:13 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Try disconnecting the electric (aux) water pump that supplies water to heater core durning idle & low RPM conditions. Any short circuit in that circuit will send the A/C into fixed operational mode (FOM). Also the windings in the mono heat valve will do the same thing.
If the incar temp sensor goes open or short you will have the same results.

------------------
MERCEDES BENZ MASTER GUILD TECHNICIAN
ASE MASTER TECHNICIAN
27 YEARS DEALER M.B. TECH
190E 2.3 ITS RACECAR

Reply With Quote
  #3  
Old 10-05-2003, 12:05 AM
Cigar Havana's Avatar
Registered User
 
Join Date: Jan 2003
Location: Toronto Canada
Posts: 379
In car temp. sensor

Could you tell me the location of the in-car temp sensor on a 1989 420 sel?
__________________
1989 420 SEL
Reply With Quote
  #4  
Old 10-05-2003, 12:22 AM
Registered User
 
Join Date: Jan 2001
Location: oregon
Posts: 2,013
if it's the same as the 86 it's on the left side of the panel on the roof between the sunvisors.........
William Rogers........
Reply With Quote
  #5  
Old 10-05-2003, 07:12 PM
Cigar Havana's Avatar
Registered User
 
Join Date: Jan 2003
Location: Toronto Canada
Posts: 379
Only the interior front cabin light is between the sun visors. Any other choices?
__________________
1989 420 SEL
Reply With Quote
  #6  
Old 10-05-2003, 11:11 PM
Registered User
 
Join Date: Jan 2001
Location: oregon
Posts: 2,013
hmm, mines a euro model and has the sunroof control dome light and climate control sensor all on one panel there. got to be be someone with an 89........
William Rogers.........
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Running Hotter Than Normal chrisalex78 Diesel Discussion 19 11-04-2003 11:26 PM
Belinda's Rocky Mountain High (Warning: Contents Hot and Steamy) jassz Diesel Discussion 10 08-21-2003 07:55 PM
73 450SL Red Hot Exaust Manifolds Teammerritt Tech Help 10 02-16-2003 09:08 PM
300E running hot...new rad?? Zeus Tech Help 17 09-27-2002 10:35 PM
Glow Plugs - Hot and hotter? JoshMB Tech Help 2 11-27-2000 01:34 PM



All times are GMT -4. The time now is 07:41 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page