Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 02-22-2000, 05:45 PM
Registered User
 
Join Date: Feb 2000
Location: Columbus Ohio
Posts: 709
I have a 1992 300SD with an oil consumtion problem(300-400 miles a quart). I have heard this is very common with this engine. My local dealer is clueless(not many diesels in this area). I have heard that a short block replacement is the only fix...anyone have any comments/suggestions?..Car currently has 93K
Reply With Quote
  #2  
Old 02-22-2000, 09:03 PM
Moderator
 
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
As I've lived in that City, the dealer has been there forever & should know that the problem is related to PISTON & ring problems. In this very heavy car the engine is just not powerful enough.
Reply With Quote
  #3  
Old 02-22-2000, 09:49 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Also, I have seen where the turbo front seal will cause this. It will pour so much oil in the engine that it will start to clog the vacuum lines.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
  #4  
Old 02-22-2000, 11:26 PM
Aaron's Avatar
Moderator
 
Join Date: Aug 1999
Location: Cincinnati, Ohio
Posts: 1,935

Which dealer are you going to? Potter or Crown? If you're going to Ed Potter, they ought to know as much about your car as anyone else. Crown, I can't say for sure as they are a fairly new dealership, but do have one impressive facility! Come on down to Cincinnati, we'll fix you up!

------------------
Rgds,
Aaron Greenberg
MB technician
Precision Motorcars, Cincinnati, Ohio
'67 250SE Cabriolet
'77 450SL
'79 6.9 (SOLD)
'80 300SD
'85 380SE
'89 420SEL
'93 300E 2.8
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
oil change wyoo Tech Help 43 03-29-2017 03:54 PM
Mobil1 15w50 in Cold Weather jjalex Diesel Discussion 30 01-21-2004 04:54 PM
300 TD - Strange oil consumption or Suspension issue BIGRED Tech Help 0 10-07-2003 12:25 PM
oil consumption 1986 420SEL 420SEL Tech Help 5 03-03-2002 01:56 PM



All times are GMT -4. The time now is 01:34 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page