Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-07-2003, 10:41 PM
Registered User
Join Date: Jul 2002
Location: Stony Brook, NY
Posts: 160
Just went to adjust lambda but car would always stall

I went to adjust the lambda on my 1988 300SE just now. Readings are a bit on the rich side at 33-40%. I have never adjusted it before but I now have the correct meter and have read many posts. One thing I didn't see is exactly how you turn the adjustment screw. I know you press down and can feel it engage but do you do this while the car is running? Every time I push it down and just engage the adjustment screw the car stalls. I haven't even tried to turn it one way or the other and won't until I get some responses. I've read too many by people getting things screwed up.
Ron Brooks
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:18 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page