Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-23-2000, 11:49 PM
Posts: n/a

I own a 78 300 SD w116... I have owned the car for 3 months and just about have it running the way I want it ... My problem,,While trying to shoot Freon ,, I moved the main vacuum pump line. to my horror ,a large peice of the vacuum pump broke off in my hand... Apparently the previous owner JB welded the vacuum pump together... Before this incident my car was running like a top...Now my car won't turn off, and my brakes are stiff.. I called around Houston, my home town and no one has a 3 line vacuum pump.. I have a back up motor , but it has a one line vacuum pump...
Several yards here in Houston have 2 line pumps.. Could I use one of these ,, Or should I try to clean and re-JB Weld the pump back together.... Any ideas as to where I can find a 3 line pump......
Sorry for being so long winded......Thank You ...... Juan
Reply With Quote
Old 02-24-2000, 07:54 AM
Posts: n/a

Try Mercedesshop PartsShop on this website. If they don't have one, post it here again, and I think I might know where you can get a used one.

Larry Bible
'84 Euro 240D, 516K miles
'88 300E 5 Speed
Over 800,000 miles in
Mercedes automobiles
Reply With Quote
Old 02-24-2000, 09:19 AM
Posts: n/a
The early 617.95 engine vacuum pumps with two diaphragms are driven differently than the later ones. You have to use the type that came on the car or change the injection pump timer to the later type....and that is a real pain. Early pumps were driven by a splined coupler, later ones are driven by an eccentric on the face of the pump timer sprocket.

Randy D.

ASE Master Tech
Mercedes Tech 19 Years
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Is anyone running a electric vacuum pump vice using the engine driven version? Carrameow Diesel Discussion 5 08-24-2004 01:41 AM
1989 300 SEL Fuel Pump and relay question. Please help me! jermdog11 Tech Help 5 11-08-2002 01:47 PM
Leaking Vacuum Pump BlueBabyBenz Tech Help 5 10-04-2002 02:19 AM
Vacuum Pump & Check Valve Woes rob_frick Diesel Discussion 5 08-15-2002 09:52 PM
Door lock diagnosis & repair, by popular demand ncarter Tech Help 1 07-15-1999 10:24 AM

All times are GMT -4. The time now is 12:35 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page