Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-09-2003, 02:54 AM
Registered User
Join Date: May 2003
Location: Easter Long Island, NY
Posts: 37
Unhappy 420 sel 1986 Just cut off while driving

My 420 sel 1986 just cut off while driving. Would not start again. Its getting spark. I hear the pump running when I turn the ignition. 18 months ago changed fuel pump, fuel pump relay at least thats what the mechanic charged me for at that time the car was not starting also. I changed the fuel filter 19 months ago.

any help would be appreciated. I am going to change the fuel filter tomorrow.

where is the fuel pump relay located and are there any pictures on line to find relays and fuses?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:24 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page