PeachParts Mercedes ShopForum

PeachParts Mercedes ShopForum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   Doctoring the 2-3 shifting flare (http://www.peachparts.com/shopforum/tech-help/64938-doctoring-2-3-shifting-flare.html)

seacoast_benz 05-14-2003 10:36 PM

Doctoring the 2-3 shifting flare
 
Have a 20-year-old 380SL here, with about 188K on the transmission, one of the good old 722.3 four-speed autoboxes. Records from PO are reasonably good, but contain no mention of a trans rebuild.

Fluid looked okay when I first got at it, a bit dark, but not burned. Drained the torque converter (man, is that a rough job), drained the pan, dropped the pan. Nothing scary hiding in the pan itself save for a few metal flecks.

Changed the filter and gasket, with a thank you to the PartsShop folks, and refilled with clean Dexron III.

It feels crisper now that it's been serviced, but it still has a noticeable 2-3 flare. This seems to be its only vice. The other shifts are fine, it finds reverse promptly, downshifts are quick.

The car is only an occasional leisure driver, and since it's not driven to work or for long distances it doesn't require perfect dispatch reliability. Thus, I am not in a hurry to drop $2K on a new trans until it becomes imperative.

Searching the archives on this, I've found references to a spring kit that is intended to improve the crispness of the 2-3 shift and get rid of the flare. The posts here also indicate that the flare really does need to be fixed, or it'll wear out the associated clutches and bands.

What I haven't been able to figure out from the archive posts is whether the kit is a feasible install for a driveway DIY. I spoke to a local MBZ trans shop of good repute. They said, "Five hours," but jeez, at $85 per hour, I'd rather start saving towards a rebuild.

I can certainly get the pan off and the filter out of the way in a lot less than five hours!

But the big question is this: can the valve body be pulled out easily once the filter is removed, on the 722.3 trans? I have never had occasion to find out. It seems that the spring should be easy to put in if the VB is accessible.

haasman 05-15-2003 01:19 AM

I am not familiar with your trans but .... Does your trans have a vacuum modulator? Does it have the external pressure adjuster on the side?

Someone posted several months ago that in checking the vacuum line to the trans, they found the rubber connecting piece hard and leaking. They simply replaced that three inch piece and found it made a significant difference.

Haasman

Larry Smith 05-15-2003 03:28 AM

I have a 1990 300ce 24v with the same problem . Can some please tell me where the vacuum pipe and adjuster are located
Thanks
Larry

seacoast_benz 05-19-2003 05:02 PM


I am not familiar with your trans but .... Does your trans have a vacuum modulator? Does it have the external pressure adjuster on the side?

Someone posted several months ago that in checking the vacuum line to the trans, they found the rubber connecting piece hard and leaking. They simply replaced that three inch piece and found it made a significant difference.


I did take a careful look at the externals when I was doing the filter change, and it all seemed visually okay.

And a vacuum bug would bite in ways other than just the 2-3 shift, yes? That one flare seems to be the only thing wrong on this unit.

I did finally get a confirm that the K1 spring kit will be installable from below, and I am going to throw one in to my next parts order and give it a try. It'll be a few weeks -- have to fix an overheating issue first.

s/b

toboris_w 06-05-2003 12:50 AM

Guys,

I finally fixed my flare problem. My 190 was so bad that it would snatch my girlfriend dress right off after every date, HAHAHA. I replaced the Modulator vacuum rubber hose and adjusted the Modulator with the T shaped key (turn clockwise) behind the rubber cap located on the Modulator. The Modulator is located on the left side of the transmission right over the main plug.

Note: The vacuum hose is hard to replace. Your best bet is to use to pair of needle nose pliers.

Hope this helps
:D

moparmike 06-05-2003 02:06 AM

My 380 SEL does the same thing, w/ 200k on it. When cold, it flares very badly, in the 2-3 shift and sometimes a little in the 3-4. When it finally warms up, it goes away.

However, it takes a sec to find reverse. When it does, it finds it quite hard and tries to take off. If I wasnt worried about it, I would say it has the power in reverse to pull a house.

Please let us know how your transmission goes.

Thanks,


All times are GMT -4. The time now is 09:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website