Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 02-27-2000, 05:55 PM
Posts: n/a
In a 1990 300E 2.6. The oil light comes on every time I make a left turn and ONLY when I make left turns. The oil pressure gauge reads normal, and the oil level is perfect. what the heck is going on?

While I'm on the topic of crazy problems, listen to this. The left headlight doesn't work. I put a new bulb (9004), nothing. Checked fuses, nothing. wiring looks good. I see nothing that would cause this. The car hase never been wrecked, in fact the car is like new with the exception that the light does not work. Do these cars have lamp control modules like BMW? Could this be the problem?

- Blizzak454
Reply With Quote
Old 02-28-2000, 08:08 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
You do have a lamp control module. I'd look at the plug that goes to the bulb. I have seen them melt on the inside. Also just install a new fuse. They will look OK, and have a hairline crack or the top will be fried.

1981 280GE SWB
1987 16V

Reply With Quote
Old 02-28-2000, 08:36 PM
Registered User
Join Date: Jan 2000
Location: New Bedford, MA USA
Posts: 1,583
As far as the oil light coming on goes. When you next drain the oil, remove the sensor and clean it off. That may do it, however if not, then it's reading the change in the sump when cornering too quickly and will probably need to be replaced. I had something similar with coolant level sensor. They are not the same but work on similar principle. Cleaned it up and it worked fine. May just have a bad ground or the sensor element is cruddy. Hope this helps..

Jeff L
1987 300e
1989 300e
1987 BMW 325
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
93' 300E Low Oil Indicator light on....and more pulix Tech Help 14 05-24-2004 10:59 AM
Demystifying Oil - General high-level info about oil haasman Tech Help 6 04-21-2004 02:28 AM
OM603 - oil leak from exhaust port with new head! gsxr Diesel Discussion 27 04-06-2003 03:12 PM
Two Problems: A/C & Oil Light Tump Tech Help 6 06-18-2002 04:57 PM

All times are GMT -4. The time now is 10:56 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page