Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-18-2003, 03:07 PM
300SDL
Guest
 
Posts: n/a
HELP!! power steering pump

126 300sdl,
I have removed, re-placed, reinstalled everything about 5 times and it still has yet to work, does anyone have any idea of what i could possibly be doing wrong? Ive jacked up the front end, turned the wheel side to side and still nothing. It seems I have no pressure... Anyone?? thanks,
Bob
Reply With Quote
  #2  
Old 05-18-2003, 04:32 PM
Registered User
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
more details

you gotta give a bit more detail then this, but the only rease I see is if the feed and return line have been mixed up, if that's even possible...


xp
__________________
1985 190E 2.3L - a constant project.
Reply With Quote
  #3  
Old 05-18-2003, 05:51 PM
300SDL
Guest
 
Posts: n/a
details

The pump leaks, not sure where i believe it is in the front I replaced everything. Even the filter and fluid i have bled the lines multiple times and everytime i have done this there is still no power to the pump. I am thinking that im just going to pick up one at a junkyard tomorow, which models are interchangeable? i think, correcct me if im wrong, I have the Vickers pump. Do other 300D's have this pump? thanks agian,
Bob

86 300sdl
Reply With Quote
  #4  
Old 05-18-2003, 08:18 PM
Registered User
 
Join Date: Oct 2002
Location: Toronto, Canada
Posts: 700
a good junk yard is a great source for good as new parts.

I just got a differential replaced this way, got one just after a rebuilt, the donor car was totaled from behind, but the differential was not touched.

xp
__________________
1985 190E 2.3L - a constant project.
Reply With Quote
  #5  
Old 05-19-2003, 10:13 AM
300SDL
Guest
 
Posts: n/a
are all Vickers and ZF pumps the same or do they have different models?
Reply With Quote
  #6  
Old 05-19-2003, 07:15 PM
EricSilver's Avatar
Registered User
 
Join Date: Mar 2000
Location: Fairfax, VA
Posts: 1,216
Vickers and ZF are *not* the same.

Here is a description, with photos, of my ZF pump rebuild/reseal. Hope it helps.

Checklist: PS Pump Re-Seal

If everything else was done correctly, my suspicioin is that your impeller vanes (you'll see what they are in the above link) are not sliding in and out of their slots as they should.
__________________
2001 E430 4matic
122,xxx miles
Black/Charcoal Interior

------------------------------------
Gone but not Forgotten:
1995 E320, 252,xxx miles, Black/Grey
1989 260E, 223,00 miles, Black/Black
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page