Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 03-03-2000, 09:45 PM
Registered User
 
Join Date: Jan 2000
Location: Pittsburgh, PA, USA
Posts: 86
I just replaced the pushbutton unit on an 83' 500sl with a refurb from mercedesshop. The blower never came on before. After replacing the unit the blower does work. However when the blower is running, regardless of which button is pushed (except off) air comes out of the three center vents. Very little air comes from the footwells. If I close the center vents the air seems to be diverted to the defroster vents. There was an aftermarket stereo installed when I got the car. During installation could they have damaged something. Or does this sound like a more common problem. I've pretty much accepted the fact that I'm going to have to replace everything in this car. So what's next?
Reply With Quote
  #2  
Old 03-03-2000, 10:14 PM
Registered User
 
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
Be sure that the wires are in the right side of the control unit. I have seen them swaped on many occasions. It usually does not hurt anything, but should be checked. You have to get the CD or the manual to check this. There is a good section on climate control in the CD.

------------------
Benzmac:
1981 280GE SWB
1987 16V
ASE CERTIFIED MASTER AUTO TECHNICIAN
SERVICE MANAGER FOR 14 BAY FACILITY
MERCEDES SPECIALIST 8 YRS
PARTNER IN MERCEDESSHOP.COM


Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Need non-working climate control, temperature and cruise control modules mplafleur Tech Help 1 03-18-2007 07:24 PM
Climate control problems mnoll4060 Tech Help 7 10-05-2004 01:57 AM
Climate Control in 420SEL flips from cold to hot William Tech Help 1 08-15-2003 07:17 AM
380SL climate control problem mike380 Tech Help 2 04-14-2003 02:33 AM



All times are GMT -4. The time now is 01:22 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page