Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-21-2003, 03:54 PM
stroked 1/2 dzn's Avatar
Registered User
Join Date: Nov 2002
Location: Houston
Posts: 43
SRS airbag light on a W202

My SRS light is coming on & staying on for about 1-2 minutes after EVERY start up now. Ideas anybody?????
'96 C36 ///AMG

Last edited by stroked 1/2 dzn; 05-22-2003 at 01:43 AM.
Reply With Quote
Old 05-22-2003, 01:43 AM
stroked 1/2 dzn's Avatar
Registered User
Join Date: Nov 2002
Location: Houston
Posts: 43
Anybody got an opinion why?
'96 C36 ///AMG
Reply With Quote
Old 05-22-2003, 10:15 AM
G-Benz's Avatar
Razorback Soccer Dad
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
I have the same problem on my 95 SL. Started immediately after I pulled the gauge cluster to replace some bulbs and disconnected the cluster harness to completely remove the cluster.

I have heard that a bad seatbelt switch can cause the light to come on, but your best bet is to pull codes. That's what I will eventually do when I get time...
2009 ML350 (84K) - Family vehicle
2001 CLK430 Cabriolet (71K) - Wife's car
2005 BMW 645CI (124K) - My daily driver
2012 Mustang V6 (60K) - Daughter's car
Reply With Quote
Old 05-22-2003, 07:56 PM
Registered User
Join Date: Jan 2003
Location: Fort Gratiot, MI
Posts: 35
I have a 94 C220 that has had the problem at least twice before. Both times it was the driver seat belt buckle. A search of this site will recommend that you take the car to a dealer and have the diagnostics done to verify the source of the problem which could be at the least either seat belt buckle. I'm at the point of going through this myself. I will buy the buckle and install myself after the diagnostics. Then the dealer will have to clear the code is my understanding, but I need to do the search to verify.
Reply With Quote
Old 05-22-2003, 09:53 PM
blackmercedes's Avatar
Just a guy
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
99% of the time the reason for the problem you have described on the W202 chassis it is the seatbelt buckle.
John Shellenberg
1998 C230 "Black Betty" 240K

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:33 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page