Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-23-2003, 04:13 PM
Registered User
Join Date: Feb 2001
Posts: 84
question on lamp control relay

In my 90 300CE, my idiot light came on and rear side marker light stopped working. It had blown a fuse. I replaced it and it blew the fuse again. I finally did my electricla diagnosis and it was the light control relay. I removed and opened it and found one of the metal links was burnt. So I soldered a wire in its place. there is no short in the wire running from the fuse to rear. also, there is no short in the tail lamp either.
My light does work now but the idiot light stays on.
Anyone knows the schematics of the relay to see what capacitor or whatever needs to be replaced.
The new part is like $150 by mail order.
any advice would be helpful.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page