Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-24-2003, 02:56 PM
Registered User
Join Date: Nov 2002
Location: Frankfort, Il.
Posts: 264
voltage regulator

Replaced the battery in my C230 this past Jan. after a 140000 miles. The car was fine until the other day it wouldnt start. Put the battery on the charger and it was only half down. Could I need a new voltage regulator? I would rather replace the regulator then the alternator. Any ideas would be appreciated. I did check for any battery drain and as far as I could tell there isnt any.
'05 Ford Escape 100,000 miles
'87 560SL 92000 miles
'89 300TE 199,000 miles
'02 Audi TT 100,000 miles
'00 Ford Excursion V-10 121000 miles
'92 Mercury Capri 100000 miles
'02 BMW 325XI 60000 miles
'92 230CE 160000
'87 BMW 535SI 160,000 miles
'93 Rinker Captiva 209
5 Kids
2 Dogs
1 Wife
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page