Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-29-2003, 01:06 AM
Posts: n/a
no oil pressure

My 1992 500 Sel has been sitting for several months.It started right up but ASR light stayed on. I also noticed oil pressure seemed very low,but went up when i accelerated. After driving for 10 minutes on highway the oil light dropped to 0 and warning light came on. oil was full and engine sounds good. Any suggestions?Thanks
Reply With Quote
Old 05-29-2003, 01:32 AM
Registered User
Join Date: Mar 2003
Location: Southern California
Posts: 2,010
Was the oil fresh and clean when it was parked or old and dirty? Dirty oil can sludge up over time and clog the inlet. It would be very expensive to overhaul your engine, so I would suggest you take no chances. The pan needs to come off for a thorough inspection of the oiling system.

Any time a car is expected to not be used for several months the oil should be changed if it has more than about a thousand miles of use.

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:58 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page