Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-02-2003, 03:46 PM
Posts: n/a
battery Light still on......But

Ok my Dad gave me the famous "idiot light" last night and I found the following; OK - I tested those 2 white fuses and to the side that little green speaker looking wire with key out, key turned on, and car turned on. Idiot light lit up on everything except the white fuse on the right. It seems like there is no power going to it. Could that be my problemo?? And my fuse box - when key is out only first one lights up. With key turned on about half more, with car on - same. Shouldnt they all light up when car is on?? Please let me know. My (&*(&^*(^(*&*()%$#@#$!@# Ex left my car like this. Thanks

Attached Thumbnails
battery Light still on......But-hotwire2.jpg  
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:42 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page