Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-04-2003, 02:18 PM
Registered User
Join Date: Jun 2003
Location: Cyprus
Posts: 12
Problems with my 300CE!!

I have recently replaced my engine in my 1988 300CE with a used one that had about 65k miles on it(That' what the owner said anyway). This engine idles rough when in traffic. Took the car to the dealer and they said that I had to replace the valve seals because it was letting oil in the #6 cyl. Hence the fact that every 200 miles it needed 1 quart of oil. The seals were replaced and it gave a "much better oil consumption". When I get stuck in traffic though it still does the same thing. Unless I drive it on a long stretch e.g freeway to get rid of all the carbon or oil deposits, it just doesn't work right. You do that and then it's fine until I let it idle again. Any ideas???
I also need to know where the cruise conrol amplifier and relay are located for replacement. Is this a DIY thing if I have the replacement parts?

Reply With Quote
Old 06-04-2003, 06:07 PM
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,503
When you say that the car idles rough when in traffic, do you mean the car idles rough when the car is stopped and idling?

Or, do you mean that you enginen runs rough when moving at a slow speed / stop and go traffic?

Do you still have oil consumption? If so, could be worn valve guides, but the dealer should've checked for that.

Idle problem could be a stuck EGR valve.
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 01:48 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page