Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-05-2003, 08:35 AM
LarryBible
Guest
 
Posts: n/a
300E, Water in Passenger Floorboard

When it rains, water finds its way to the area below the front passenger floor mat.

Are there any under hood or cowl drains that I should check. I have eliminated the evaporator drain as the source of water. I have checked all the areas I can see looking for drains that might be clogged and causing this problem.

Any sharing of related experience is appreciated.

Have a great day,
Reply With Quote
  #2  
Old 06-05-2003, 08:47 AM
Tomit1's Avatar
Registered User
 
Join Date: Feb 2003
Location: Finland
Posts: 50
I have had the same problem with my 300 TE -92, (and maybe I still have, not sure yet). I have gone through all the drains, in front of the windshield and in the sunroof, but they were all OK.
Also AC drainage OK. I think in my case, this is a leaking windshield through the side seal. There wasnt perfect contact with the glass and the rubber seal. The windshield has been changed once. So I applied a sealant through all the windshield sides. I am not sure yet if it corrected the problem, it hasnt rained lately.
This is a really annoying problem.
Reply With Quote
  #3  
Old 06-05-2003, 04:39 PM
Registered User
 
Join Date: Nov 2000
Location: Houston, TX, USA
Posts: 185
Larry...

I have the SAME problem in the 400E. When I go through the automatic high pressure car wash or when it rains hard, it soaks the passenger floorboard. The problem (at least on my car) is the waterproof boot that surrounds a couple of wiring harnesses that go from the engine compartment to the cabin through the firewall has cracked. On my car it is the uppermost wiring harness on the firewall on the passenger side (way up in the corner.) Look at yours and see if the boot is cracked too.

Hope this helps yall....Peter
__________________
Peter Balias
pbalias@hotmail.com
1992 400E
http://albums.photopoint.com/j/View?...103&p=46824109
Reply With Quote
  #4  
Old 06-10-2003, 04:56 PM
Tomit1's Avatar
Registered User
 
Join Date: Feb 2003
Location: Finland
Posts: 50
Finaly found the water leak

Now I found my water leak. It is the rubber tubing between the chassis and the front door (on both front doors!)which was not connected in the chassis side ( where all the door wiring goes through). I connected it with some silicon, and tested it with my garden hose. Nothing comes through anymore. All this trouble for this simple thing, but i'm glad I found it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:35 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page