Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-05-2003, 08:11 AM
Registered User
Join Date: Jun 2001
Posts: 259
Shuddering brakes but not all the time?

86 560sl-205kmiles

Lately on intermdiate to hard brake, sometimes I get shuddering all the way through the pedal and the steering wheel-shakes pretty good too. Weird thing is, it will do it a couple of times in a row then brake smooth and quiet with no shudder a time or two then shudder some more. Seems to be no rhyme or reason. And I'm a grownup so I'm driving it nice and easy.

Last week I had the tires rotated and the brakes checked. According to a brake shop, there was still plenty of meat on the rotors and the pads were ok for awhile.

What does that sound like? Out of balance tires? ABS sensor?Ball joints? (steering is good and true) Something else maybe?


J. Boggs
Reply With Quote
Old 06-05-2003, 09:32 AM
Registered User
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
I would guess pad contaimination from leaking fluid, or a hanging caliper.

Reply With Quote
Old 06-05-2003, 01:49 PM
Posts: n/a
When was the last time you flushed your brake system?

Old brake fluid will cause that feeling. The brake fluid gets contaminated with water and grime.
Reply With Quote
Old 06-05-2003, 02:00 PM
mike690003's Avatar
Registered User
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
My 300e brakes shudder at low speeds(5mph). what could that be from?
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS

Reply With Quote
Old 06-05-2003, 02:09 PM
Posts: n/a
Shuddering at low speeds is prolly your ABS...mine does it too, but i need a new ABS Control Unit, not worth the money so i just deal with it. Yours might just be a sensor that is out of wack, who knows
Reply With Quote
Old 06-05-2003, 04:00 PM
Registered User
Join Date: Jul 2002
Location: Dallas
Posts: 330
If your brakes were fine before the rotation, I bet the wheels need balancing.
Reply With Quote
Old 06-05-2003, 11:16 PM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096

The 300E had the same brake shudder a low speeds and turned out to be a bad tie rod.

The 190E had brake shudder at low and medium speeds and it turned out to be a bad steering damper.

I knew a guy who had severe shudder in the front-end at any speed right before one of his front wheels fell off .... but that's another story.

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)

Last edited by haasman; 06-05-2003 at 11:22 PM.
Reply With Quote
Old 06-06-2003, 12:18 AM
1991300SEL's Avatar
Registered User
Join Date: May 2003
Posts: 497
Rotors could be warped.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:02 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page