Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-17-2003, 10:29 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
1994 E420 Hesitation

Ok here is what it's doing.
When starting to accelerate just as I start rolling the car always hesitates. There is no noise associated with it. What is the case of this. It really bugs me especially we I put my foot in it and it does it. Grrrrrr!!!!!
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #2  
Old 06-17-2003, 11:36 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
11 views and no thought/opinions????
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #3  
Old 06-17-2003, 11:57 PM
Registered User
 
Join Date: May 2003
Location: Dallas, TX
Posts: 21
Had the same problem with my 92 300ce, spent over US$1k. I think the two shops i went took advantage of my mechanical ignorance. They replaced the oxygen sensor, egr valve, flywheel sensor & vacuum switch. there are a lot of threads about hesitation problem, some were fixed by a simple replacement of plugs to non platinum or changing plug resistors. Post your fix once done, and good luck
Reply With Quote
  #4  
Old 06-18-2003, 02:02 AM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,078
I finally got around to bringing my car back into the shop in order to see about the check engine light.
Previously, the ignition module (NOT cheap!) was replaced after loosing 4 cylinders out of the blue, while running a diagnostic test procedure on the airpump.
The error codes at this sitting were somewhere around 25! One of them I believed to be legit, which was the brake light switch - a few weeks ago, my ASR and ABS lights would come on at different times w/o provocation (they did stop coming on this past week). Another code proposed that the ignition module was bad (again). Now, I am told that the fuel injection wiring harness is shot, and needs replacing. Apparently the bad insulation gremlin reared it ugly head in that harness. The rest are apparently ok, although I am not sure if they have peeked at them of not.
If you do not suspect your harness(es) to be bad, then I would take a look at the caps and rotors.....might it be time to replace those?

Good luck...

-Larry
__________________
"...rationality of thought imposes a limit on a person's concept of his relation to the cosmos." -Nash

04/71 280SE 195k
09 Jetta TDI
Reply With Quote
  #5  
Old 06-18-2003, 10:03 AM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Angry

Just had the wiring harness replaced a month ago. Had that done due to a surging problem. Surging problem still exists after spending 1k to have it replaced.....grrrrr. ): NOW I have a hesitation problem AND a surging problem. I think it's time for a new E500.....geez there alot.
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #6  
Old 06-18-2003, 12:00 PM
Registered User
 
Join Date: Jun 2003
Location: Chapel Hill, NC
Posts: 55
DON'T BELIEVE THE HYPE!

Dude, be wise and don't believe the hype. Never let emotions get the best of you, or you'll get hosed. Things that seem complex are typically very simple and things that seem simple, are usually complex.

Your solution:

VALVOLINE "COMPLETE" FUEL SYSTEM TREATMENT.
Cleans and protects entire fuel system.
Guaranteed to restore maximum power and performance, eliminate rough idle, hesitation and knocking.

-Restores lost power and performance
-Eliminates hesitation, surging and rough idle
-Reduces harmful emissions
-Prevents pre-ignition knock
-Eliminates the need for higher octane gasoline (not applicable for us here since we must use premium)
-Prevents fuel system corrosion

Cleans:
-Fuel Injectors
-Combustion Chambers
-Intake Valves
-Intake Runners
-Ports
-Cylinder Heads
-Piston Heads
-Carburetors


Don't you spend a dime! Go to AutoZone and get some of this stuff. Put it in right before you're about to go driving. It cleans your fuel system completely, so it needs to be put in your tank, as your fuel system is about to be active. You don't have to go driving the entire tank of gas out in order for this to work, however, put a large amount of gas in the tank, pour a container of this juice in your tank and ride around some.

Eventually, your car will be so quick in responding to you 'gassing it' that you'll feel like you have a new engine. Take this from a 23 yr old that's been raped by mechanics.

Cars are like women: keep it simple and it usually works better.

The container will say "Once a year treatment."

So put this formula in there once. This "complete" fuel system cleaner is to be used once a year though, so at each oil change thereafter, simply put the Valvoline "Fuel Injector" cleaner in, when you perform each your next 3 oil changes. Then on the next (assuming you do 3,000K oil changes. If not, do the math yourself), put your "Once a Year COMPLETE" cleaner in there again.

Don't waste a dime doing anything else. This formula will cost around $20.

Be blessed dear friend! I am here to help others as much as possible. This board should be to help us get cheaper service, no matter what. We've been molested enough! And frankly, I'm tired of running the 'the man' for everything.

Last edited by Duke1Law; 06-18-2003 at 12:06 PM.
Reply With Quote
  #7  
Old 06-18-2003, 05:56 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
What the heck kind of posting is the one above this one? Is it an add or something. Anyways, anyone else have some input?
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #8  
Old 06-18-2003, 07:55 PM
Registered User
 
Join Date: May 2002
Posts: 403
Maybe your fuel filter may be dirty? When's the last time you replaced it? Don't know what the previous post is all about - I do deduce that Duke1law is suggesting that you use some type of "cleaner" to clear out anything that might be causing poor drivablitiy (like using Techron to clean out injectors).
Reply With Quote
  #9  
Old 06-18-2003, 08:01 PM
Registered User
 
Join Date: Oct 2002
Location: Colorado Springs
Posts: 481
94E420,
I am having a similar problem although mine actually stalls.I believe it is related to the Air Mass FLow but have a few more tests to run. Off course mine is on a different engine style and older and simpler 560 so they may be completely different.
m
__________________
Martin Ingram
Colorado Springs
2005 320 CDI
2006.5 VW Jetta TDI
1991 560SEL (179000 Sold)
1972 280SEL 4.5 ('The Lead Sled' 320000 miles when sold.)
1972 220D (225000 when sold)
Reply With Quote
  #10  
Old 06-19-2003, 12:09 AM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,078
94E420,

You haven't said yet, wether you checked/replaced the caps and rotors. I replaced mine at 92k and they needed it. You car's mileage is not that far off from mine, it wouldn't hurt to take a gander if you haven't already.


mhingram,

Those two V8's are quite different. Different injection system, twice the amount of valves, and two caps, rotors, and coils, just to name a few. My 420SEL is said to have 201HP, the E420 has 275. (kind of amazing, isn't it?)

-Larry
__________________
"...rationality of thought imposes a limit on a person's concept of his relation to the cosmos." -Nash

04/71 280SE 195k
09 Jetta TDI
Reply With Quote
  #11  
Old 06-19-2003, 12:27 AM
Registered User
 
Join Date: Jun 2003
Location: Chapel Hill, NC
Posts: 55
94, don't worry, I won't reply to another thread from you again. Go...spend $300 for nothing by having your ignorance taken advantage of. With your symptoms, common sense says before you go have anything done to it, clean your entire fuel system.

As the last guy said, my post was rather simple: Buy some Valvoline Fuel System Cleaner and call it a day. Your fuel system is dirty.

The rest of the "nonsense" was me actually taking the time and typing all of the details of the crap out, in order to help you!
Reply With Quote
  #12  
Old 06-19-2003, 12:30 AM
Registered User
 
Join Date: Jun 2003
Location: Chapel Hill, NC
Posts: 55
Arrow

With appreciation and common sense such as that, I see why Roy Williams left Kansas.
Reply With Quote
  #13  
Old 06-19-2003, 12:38 AM
Moderator
 
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,508
My best guess would be a problem with your Mass Air Meter.
__________________
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote
  #14  
Old 06-21-2003, 11:00 PM
Registered User
 
Join Date: Mar 2003
Location: Carmel, CA
Posts: 301
Duke,
Do you have some anger issues you need to deal with or, perhaps an anger management class would help. I WAS JUST JOKING!!! Get a sense of humor already!!! Thanks for your input!

And NO I don't have a dog named Toto!!!!

XOXO
Dorothy's Husband
__________________
1973 280 - Sold
1980 300SD - Sold
1982 240D - Stolen
1988 300E - Sold
1989 260E - Sold
1989 560SEL
1994 E420 - Sold
1997 E420
2005 CL500
Reply With Quote
  #15  
Old 06-22-2003, 03:29 PM
Larry Delor's Avatar
What, Me Worry?
 
Join Date: Jun 1999
Location: Sarasota, Fl.
Posts: 3,078
With the hope that you have relaxed a little, I was wondering if you could answer the question that I asked 5 days ago.
__________________
"...rationality of thought imposes a limit on a person's concept of his relation to the cosmos." -Nash

04/71 280SE 195k
09 Jetta TDI
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page