Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 06-23-2003, 12:13 PM
Registered User
 
Join Date: Mar 2001
Posts: 223
190e Stalling

I have a 190e that is stalling now and then and has been doing it for 3 years or so. When it starts to happen I replace the overvoltage protection relay OVP and it stops for about 6-9 months then I replace the relay again.
Any ideas on what could be causing this?
__________________
1996 E320
2000 C230 Kompressor
1988 190e 2.3 - 225K miles, owned for 7 years. I cannot say enough good things about this car. Very well built, even at 225 it ran like new.
Reply With Quote
  #2  
Old 06-24-2003, 07:17 AM
Registered User
 
Join Date: Mar 2001
Posts: 223
I have researched the posts, please need help here
__________________
1996 E320
2000 C230 Kompressor
1988 190e 2.3 - 225K miles, owned for 7 years. I cannot say enough good things about this car. Very well built, even at 225 it ran like new.
Reply With Quote
  #3  
Old 06-24-2003, 11:27 AM
Registered User
 
Join Date: Jul 2001
Location: SoCal
Posts: 1,303
I determined some symptoms I had were likely due to the OVP, so I replaced it. The symptoms returned quickly, so I disassembled the new OVP and resoldered internal connections to the connector pins, which looked doubtful. The problem appears to occur due to an assembly technique problem. It seems to have been fine since then, but that has only been a few months.

I am not impressed with the design that uses a mechanical relay in this critical function. If I think it is giving future problems, I may investigate replacing the internal relay with a solid-state component.

This might not be what is causing your stalling though. If it is the only thing you have checked, note that many parts can wear out to cause operation problems with your engine, including stalling. If there are any other symptoms of incorrect operation, whether they annoy you or not, and if you have done any other work on the system, it would help to note it here.

Steve
Reply With Quote
  #4  
Old 06-25-2003, 04:44 AM
Registered User
 
Join Date: Mar 2001
Posts: 223
Appreciate the replay steve, the car runs great other than the stalling then it goes away for 6 months or more after I replace the relay. Ah maybe its best to just keep doing it its at 210k miles now but runs like a dream-the oil is still transparent clean after 5000 miles amazing
__________________
1996 E320
2000 C230 Kompressor
1988 190e 2.3 - 225K miles, owned for 7 years. I cannot say enough good things about this car. Very well built, even at 225 it ran like new.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:42 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page