Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-23-2003, 01:42 PM
Posts: n/a
cruise control 1988 420sel

I am having problem with cruise. Sometimes it works with no problems, other times when setting cruise it either accelerates until you step on brake or the throttle justs keeps accel. and decell until you step on brake.
Reply With Quote
Old 06-24-2003, 09:16 AM
Registered User
Join Date: Dec 2002
Posts: 305
I know this one!!!!!

Do a search for cruise control amplifier.. You will find more info than you will ever need. It is highly likely that that is the cause of your problem.. It's very common..

89 300SEL Money Pit

92 Blown Buick Ultra Pimpmobile 220K and adding 1K per week

88 Wagoneer Slightly modified (Not for soccer moms)

04 Kia Sedona with every option... NICE
Reply With Quote
Old 06-24-2003, 12:26 PM
jbaj007's Avatar
Registered User
Join Date: Jun 2001
Location: Santa Monica, CA
Posts: 2,053
Remove the cruise control stalk from the steering column and clean the contacts in the switches first. Simple and cheap. Then move on up the diagnostic tree.
The Golden Rule

1984 300SD (bought new, sold it in 1988, bought it back 13 yrs. later)
Reply With Quote
Old 06-24-2003, 01:56 PM
Registered User
Join Date: May 2003
Location: Rockville, MD
Posts: 96
Re: Cruise Control

I would start with the stalk, also. It shouldn't have any play in it and should snap back into the center position after being moved in any direction. Mine lost this elasticity? in the Arizona sun and had a tendency to auto engage-disengage similar to what you describe. Scary. Replaced the stalk at the dealership for about $200 total but the cruise still doesn't work...on to the amplifier. Either way, I would have needed the new stalk and at least now it doesn't auto engage in city traffic!

87 420SEL
00 C230K
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 06:34 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page