Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 06-28-2003, 08:14 PM
Registered User
Join Date: Oct 2002
Location: Australia
Posts: 44
Angry 124 E280 Idle too high !

124 E280 1996 idling at 1000-1200 rpm, very smoothly and drives perfect. Control units are clean, no codes. Wiring loom Okay too. No vac leaks. I suspect throttle control unit, an expensive guess though.
Any comments and help would be great.
Many thanks.
Reply With Quote
Old 06-28-2003, 08:53 PM
mike690003's Avatar
Registered User
Join Date: Apr 2003
Location: Miami,FL
Posts: 807
My first suggestion is to cleac the throttle plate with, of course "Throttle Plate Cleaner",

My second is to: Lube the accelerator cable, dirt and rust can make the cable "stick".

My third is to: Check the coolant temp sensor, mine was unplugged and my car idled at 1200 rpm, I peeked under the hood and I saw the sensor was unplugged.

Hope this helps
1987 mercedes 300E
1995 e320 conversion(hated the 300e grill)
HID/Xenon (D2S)
Keyless Entry
Monochromatic Paint (Custom Blue)
Smoked Tails
Flat Badged (front)
Debadged (rear)
custom "carbon fiber" console
18 inch HP EVO rims
Sold! Now I drive a Monte Carlo SS

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page