Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-01-2003, 08:55 AM
Posts: n/a
2003 E500

It took me awhile to find a MB board and maybe you have some insight to this.
I bought a new E500 in October 02 and had multiple electrical problems including tele-aid system, lights, radio, and most disturbingly air-bag's only working intermittently.
They replaced the main computer once and some other parts several times. In May they finally just gave me a new car.
Well guess what, it was in shop for 10 days because it has same audio problem (I was told they keep getting too hot). They had to order new fix from Germany and my audio system lasted another week and a half but is out again. Car has 859 miles and has been in the shop for 12 days since I got the new one.
I am at the end of my rope. Is this a common occurrence or have you heard of any other major issues with the new E class?
This is my first post so if in the wrong section, please move.
Reply With Quote
Old 07-01-2003, 09:24 AM
I told you so!
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,741
Your car may be suffering from a phenomenon of being too complex and too difficult to repair for its own good. This was discussed a couple of weeks back in the following thread:

Mercedes Quality

There's a disturbing trend where cars are spending more time in the shop than ever before. I hate to think what will happen with these cars when they come off warranty! I can only think that resale values will drop considerably.
95 E320 Cabriolet, 131K
Reply With Quote
Old 07-01-2003, 09:41 AM
Registered User
Join Date: Apr 2002
Location: a space in time
Posts: 132

Spotty, I feel for you. I just went thru an issue with my 93 600sel and I hope it is fixed (just got the car back). I'm doing the "test drive" thing now. I managed to keep my cool, realizing that it is a 10 year old car, but I'm not sure that I could handle having a new car and going thru what you are. I just might lose it. I sincerely hope that they get this sorted out for you in a timely manner. It is disturbing to hear that the 2nd car has the same problems....I had been lusting after an e500 that is at the dealership...I think I'll wait. Please keep us posted.
Best of luck.

93 sl600
93 600sel

A mercedes is an inanimate object and therefore must respond to logic and reason.
Reply With Quote
Old 07-01-2003, 09:42 AM
Join Date: Dec 2001
Location: Southern California, U.S.A.
Posts: 8,503
Well, if there's a positive side to this, at least the dealer is taking care of the car at no charge to you.

The bad side is you have the inconvenience of buying a $50,000 car that has probably been in the shop more than you've driven it.

I think the lesson to be learned here is that it is probably not a good idea to buy a car in the first year of its model run.
Paul S.

2001 E430, Bourdeaux Red, Oyster interior.
79,200 miles.

1973 280SE 4.5, 170,000 miles. 568 Signal Red, Black MB Tex. "The Red Baron".
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 03:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page