Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-10-2003, 10:41 AM
Tom McMenamin's Avatar
Registered User
Join Date: Aug 2001
Location: Orange Park Florida
Posts: 363
More Info!

Spoke to the Machine shop1 He claims that no valves were bent. He claims that the two valves that were bad comes from two cylinders running lean.

Either Injector problem, wiring problem or something else causing the cylinder to run lean and develop the problem
He claims that the condition would take 15000 miles to manifest itself.

Again, how can we get such good performance prior to chain replacement, get a valve noise after chain installation and have these type of problems discovered?

The caps I referred to in the above post are called lash caps and as stated two of these were thinner than all of the rest!

I'm still confused!

Can anyone give me a thought here?
1988 560SL
Black Pearl/Palamino
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:30 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page