Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-09-2003, 12:33 PM
Registered User
 
Join Date: Dec 2002
Posts: 154
What is this?????

Hey guys,

Can someone please help me identify a part. The unit in question has a cluth that is very noisy. I know it is not the AC compressor but I am not aware of anything else under the hood with a clutch. It looks like it might be a smog pump. It is on the passenger side, toward the front of the engine near the bottom.

Any ideas??

Thanks!
Reply With Quote
  #2  
Old 07-09-2003, 12:40 PM
Registered User
 
Join Date: Feb 2002
Location: Orlando, FL
Posts: 788
On a 126, that is the location of the smog pump, so I am sure that it is the same on your 140.
__________________
'86 420SE Euro
904 Midnight Blue, Gray Velour
Dad bought it new, now I own it.

"A Mercedes-Benz is like a fine wine, it only gets better with age."
Reply With Quote
  #3  
Old 07-09-2003, 12:42 PM
Registered User
 
Join Date: Dec 2002
Posts: 154
Thanks....The moer I look at it the

more it does appear to be a smog pump. Never seen one with a clutch before though. It only seems to run in the morning though. When it does it has a loud rattling noise to it. Any idea if these things are just made to be noisy. My AC comp is whisper quiet so I dont think the smog should be any louder.
Reply With Quote
  #4  
Old 07-09-2003, 01:15 PM
MikeTangas's Avatar
Senior Member
 
Join Date: Apr 2000
Location: So. Cal
Posts: 4,430
Tha AIR pump (smog) has a clutch, it is only engaged until the cold engine comes up to temp, just a couple minutes at most.
__________________
Mike Tangas
'73 280SEL 4.5 (9/72)- RIP
Only 8,173 units built from 5/71 thru 11/72

'02 CLK320 Cabriolet - wifey's mid-life crisis

2012 VW Jetta Sportwagon TDI...at least its a diesel

Non illegitemae carborundum.
Reply With Quote
  #5  
Old 07-09-2003, 06:11 PM
DR.DIESEL's Avatar
Senior Member
 
Join Date: Mar 2003
Location: Puget Sound, Washington St.
Posts: 522
They only run during cold start enrichment. When the pumps begin to have "issues" they tend to get noisy when activated.
It should only run for around 120 seconds.
Carefull, these smog pumps are spendy.
Reply With Quote
  #6  
Old 07-09-2003, 06:14 PM
Registered User
 
Join Date: Dec 2002
Posts: 154
anyone ever had one of these replaced

under the starmark warranty. The contract doesnt say anything about emmissions equipment so my guess is that it isnt covered.
Reply With Quote
  #7  
Old 07-09-2003, 06:26 PM
DR.DIESEL's Avatar
Senior Member
 
Join Date: Mar 2003
Location: Puget Sound, Washington St.
Posts: 522
I would call 1-800-for-Mercedes and ask for assistance with coverage. I would also call the dealer and check your state's
8/80 Fed emissions warranty.
Good luck.
DR.D
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page