Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-10-2003, 11:21 AM
dimas's Avatar
Registered User
Join Date: Jul 2003
Location: ct.
Posts: 1
hid and shimmy problems

why does the left control unit that controls the left xenon light on my S500 keep needing to be replaced.It will work for a day or so after being replaced with a new one, and at 500 dollars a pop I can't keep replacing it.what could the problem be .Please help,I am going nuts.

second question,I get a bad shimmy at about 45 mph I changed the shocks, the steering damper ,the bearings,did a wheel alignment 4 times ,balanced the tires 4 times and it's still there.
what else could it be?
Reply With Quote
Old 07-11-2003, 09:03 PM
Junior Member
Join Date: May 2003
Location: Jersey
Posts: 9
It is possible that your lower control arm bushings are worn, just a thought.
Reply With Quote
Old 07-11-2003, 11:16 PM
Registered User
Join Date: Mar 1999
Location: Suwanee, GA, USA
Posts: 4,712
If you do not have enough power or a good ground to the control unit, it will cause major problems.
Donnie Drummonds
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page