Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-12-2003, 02:17 PM
Registered User
Join Date: Aug 2001
Location: Evansville, Indiana
Posts: 8,150
The seven bottles of injector cleaner on an empty tank is part of your problem, it won't burn that concentrated.

Put a bottle of Techron or RedLine (these are the only two with the proper detergent) in and fill the tank with nice, high grade premium. Drive it out, then repeat, then run a full tank of clean permium, THEN check the plugs (unless you have black smoke rolling out the back). This will give you a better idea of how things are working after running a bit.

Heavier oil and a nice hour long freeway run (at speed, not stop and go) will probably clear the plugs up some, too.

1972 220D ?? miles
1988 300E 200,012
1987 300D Turbo killed 9/25/07, 275,000 miles
1985 Volvo 740 GLE Turobodiesel 218,000
1972 280 SE 4.5 165, 000 - It runs!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 08:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page