Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 07-11-2003, 03:05 PM
EricSilver's Avatar
Registered User
 
Join Date: Mar 2000
Location: Fairfax, VA
Posts: 1,215
W124 Driver's Seah Goes Down But Not Up

1989 260E


The power driver's seat on my car suddenly decided to go down, but not up again. I can hear and feel the seat motor when I move the door switch down, but feel and hear nothing when I try to raise it back up.

In reading the threads on this issue, the culprit seems to be the switch. Before I take it out and clean the contacts, etc. is there any other possible area to look at?
__________________
2001 E430 4matic
122,xxx miles
Black/Charcoal Interior

------------------------------------
Gone but not Forgotten:
1995 E320, 252,xxx miles, Black/Grey
1989 260E, 223,00 miles, Black/Black
Reply With Quote
  #2  
Old 07-11-2003, 04:37 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,745
Does it move properly with the memory buttons if you have memory seats?

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #3  
Old 07-11-2003, 07:59 PM
EricSilver's Avatar
Registered User
 
Join Date: Mar 2000
Location: Fairfax, VA
Posts: 1,215
Nope -- no memory buttons.

I am hoping it is only the switch, or is it possible for the seat motor to fail in a way that causes it to go only down but not back up again?
__________________
2001 E430 4matic
122,xxx miles
Black/Charcoal Interior

------------------------------------
Gone but not Forgotten:
1995 E320, 252,xxx miles, Black/Grey
1989 260E, 223,00 miles, Black/Black
Reply With Quote
  #4  
Old 07-11-2003, 08:41 PM
Registered User
 
Join Date: Sep 2000
Posts: 97
well, at least on the 126 300 SD (1984), I have replaced the seat switch twice and both times it was the problem.

I haven't seen the motors fail....the seat switch buttons seem to get sticky and fail. I don't know if they can be cleaned or not? Might just try replacing the swtich adn see waht happens. Even at 20 years, my seats seem to move okay. Of course, this car is different than yours.
__________________
1) 84 300SD 285K+ Miles (Ver Calif)
2) 84 300SD 175K+ Miles (Ver Federal)
Reply With Quote
  #5  
Old 07-11-2003, 10:47 PM
Registered User
 
Join Date: Mar 2002
Location: Naperville, Illinois
Posts: 92
Chances are that the culprit is the switch. The same motor is used to move the seat up or down...........you just swap the polarity of the motor to get it to reverse direction (DC motor). So, if the seat moves in one direction, it should move in the reverse direction. The switchs get gummy over time, and the gum will insulate the swiitch contacts causing the switch to fail.

You can buy a new switch (about $85 for the driver's side), or you can remove the switch and pretty much flood the switch with electrical contact cleaner. DO NOT use any oil product such as WD-40 since it will leave a film that is just as bad as the gum you are trying to remove. Get a can of electrical contact cleaner.........or TV tuner cleaner (from Radio Shack) and spray it in all the openings. At that time, cycle the switch 20 to 30 times in each direction of travel. The contact cleaner will flash off and should leave no residue. Reinstall the switch and give it a try before you put all the trim pieces back in place. If this doesn't do it, replace the switch. It's an eay repair.
Reply With Quote
  #6  
Old 07-11-2003, 11:05 PM
EricSilver's Avatar
Registered User
 
Join Date: Mar 2000
Location: Fairfax, VA
Posts: 1,215
Guys, thanks. I will do the electrical cleaner thing tomorrow.

Although I am getting used to the new "Low Rider" feel of the car, I prefer to sit high up on my throne so I can look down upon other drivers.
__________________
2001 E430 4matic
122,xxx miles
Black/Charcoal Interior

------------------------------------
Gone but not Forgotten:
1995 E320, 252,xxx miles, Black/Grey
1989 260E, 223,00 miles, Black/Black
Reply With Quote
  #7  
Old 07-16-2003, 05:16 PM
EricSilver's Avatar
Registered User
 
Join Date: Mar 2000
Location: Fairfax, VA
Posts: 1,215
The electronics cleaner spray from Radio Shack worked, though it is rather pricey -- $10.00 -- for such a small can. Now my head is once again butting up against the roof.
__________________
2001 E430 4matic
122,xxx miles
Black/Charcoal Interior

------------------------------------
Gone but not Forgotten:
1995 E320, 252,xxx miles, Black/Grey
1989 260E, 223,00 miles, Black/Black
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 04:10 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page