Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-25-2003, 05:27 AM
leoreyes69's Avatar
Registered User
Join Date: Jul 2003
Location: San Luis AZ
Posts: 9
need advice

My car takes from 10 to 20 seconds to start while cranking it,some people told me it was the fuel pump but ones it starts it runs really good, i would like more power on it but first i like to get it to start w/out no problems. Can anyone help me?
Reply With Quote
Old 07-25-2003, 09:01 AM
I told you so!
Join Date: Jun 2002
Location: Motor City, MI
Posts: 2,741
It could be any number of things. You didn't list any information about your car that may help, such as which car this and how many miles and what - if any - repair and maintenance has been done to the car.

If you suspect poor fuel delivery, this can be verified by attaching a fuel pressure gauge to it.
95 E320 Cabriolet, 131K
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:27 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page