Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 07-31-2003, 05:33 AM
Posts: n/a
W126 no recirc

My 89 560SEL air works great. The only issue is that I think the recirc vents aren't shutting when I am activating recirc.

The light on the recirc button comes on when pushed but if I am driving through a tunnel I still get a strong fume smell.

Are there vents or flaps of some sort that should be shut when pushing the recirc button?

Reply With Quote
Old 07-31-2003, 11:54 AM
sixto's Avatar
smoke gets in your eyes
Join Date: Jun 2000
Location: SF Bay Area
Posts: 18,745
If you don't have a passenger side airbag, remove the glove box liner and check the recirc flap vacuum actuators that should be visible. There are two actuators and each has two chambers.

95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:01 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page