PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   Balance / Alignment (http://www.peachparts.com/shopforum/tech-help/7239-balance-alignment.html)

Francisco 04-25-2000 01:11 PM

I just got 4 new tires for my 75 280C in Sam's Club,obviously they balanced them all, but, When I reach 75 miles/hr the car starts to vibrate, Could this be caused from a bad alignment? or balance was not done right? I noticed that the car pulls a little bit to one side, but I don't think it is a significant amount. Does anyone have any suggestion?

Thanks

Francisco GArcia
San Antonio,TX

TCCBass 04-25-2000 01:24 PM

I also purchased tires from Sam's for my 84 300DT-Michelin X Metric, T-Rated. They ride really well and seem to handle relatively well. However, they did vibrate and pull to the left. I took the car back, and the balancing wasn't anywhere near close. They rebalanced the tires as well as switched sides, and not a vibration or pull to speak of now. This is the 2nd time I have this problem with tires purchased from Sam's, and they were different stores. Don't know whether the tech didn't get enough sleep or what, but I'd try rebalancing and switching sides before the expense of alignment.
Good luck...that 280C is such an elegant design. :cool:
Robert

------------------
R Talley
84 300D-T


All times are GMT -4. The time now is 03:19 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website