Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-13-2003, 11:34 AM
Vronsky's Avatar
Enemy combatant
Join Date: Jul 2002
Location: Amsterdam, Old Europe
Posts: 838
Sagging right front side

I noticed that the right front side is sagging a bit: the amount of space/distance between the tyre and the wheel arch on the right is about one inch smaller than on the other side. The spring looks okay, bt maybe it is worn. Happened only recently.

Could there be any other causes?

'01 DT41 - M54 - A5S 325Z - 482
Reply With Quote
Old 08-13-2003, 11:47 AM
haasman's Avatar
Registered User
Join Date: Jun 2001
Location: San Francisco, CA
Posts: 3,096
You may want to check and see if your front sway bar link is broken. Look carefully as it is easy to miss the a broken end of the bracket.

Keep us posted,

'03 E320 Wagon-Sold
'95 E320 Wagon-Went to Ex
'93 190E 2.6-Wrecked
'91 300E-Went to Ex
'65 911 Coupe (#302580)
Reply With Quote
Old 08-13-2003, 11:56 PM
csnow's Avatar
Registered User
Join Date: May 2002
Location: Mass
Posts: 1,127
Just make sure that your upper spring mount is not starting to tear away from the frame. Happens sometimes. Pics posted here in the past. Scary stuff...
1986 300E 5-Speed 240k mi.
Reply With Quote
Old 08-14-2003, 12:17 PM
Pete Geither's Avatar
Half Fast Moderator
Join Date: Feb 2002
Location: Western Pa.
Posts: 2,417
We just fixed a 210 body with the upper spring mount torn from the frame. It's a diesel with 150k on it, but this should not be happening.
95 SL500 Smoke Silver, Parchment 64K
07 E350 4matic Station Wagon White 34K
02 E320 4Matic Silver/grey 80K
05 F150 Silver 44K
Reply With Quote
Old 08-15-2003, 10:02 AM
Vronsky's Avatar
Enemy combatant
Join Date: Jul 2002
Location: Amsterdam, Old Europe
Posts: 838
Bad springs (probably...)

Went to see my regular garage. Guy could find anything, so he concluded it had to be the coil, which he then replaced (incl left side one). Guess the coil had lost its stiffness (12 years old). Doesn't happen very much, he admitted. No other defects in the suspension. Height is okay now. MMMmmm...

'01 DT41 - M54 - A5S 325Z - 482
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:31 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page