Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-13-2003, 08:30 PM
Registered User
Join Date: Jun 2001
Posts: 259
Brake Question

Wife drove my 560 sl and said the brakes were making a horrible grinding sound-Yes I have a warped rotor but "grinding sound?" nah.

Today I finally heard it. Ginding to a halt like there was something torn loosed in a wheel. Stopped ok then next stop it functioned OK. Had one wheel off over the weekend and the drivers brake looked ok.

I know it would be hard to guess but what would make a sound like parts were loose in a brake (other than the obvious being parts loose in a brake?)

J. Boggs
Reply With Quote
Old 08-13-2003, 09:10 PM
Posts: n/a
Wheel bearings.........likely culprit!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:06 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page