Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-14-2003, 02:48 AM
Registered User
 
Join Date: Nov 2002
Location: Los Osos, CA
Posts: 211
Help!! My car's electrical system has gone haywire!

Hi All,
Well, after getting the sunroof lifting arms replaced by the local tech on my 300e, i got the car back to discover that several key functions were not functioning. The clock, stereo, lights near the shifter, dome light, and more do not function unless you have the key in and door open, which does me no good, as I do not like the Jeep Wrangler style doorless Mercedes, but nor do I like to drive with my stereo mia. The fuses are all still intact, unfortunately, seems the easy fix never comes my way. Any ideas?
__________________
Scott

1987 300e - The 200,000 mile TurboTechnics rocketship.
Reply With Quote
  #2  
Old 08-14-2003, 10:56 AM
1991300SEL's Avatar
Registered User
 
Join Date: May 2003
Posts: 545
Was it doing this before the recent work? If not, take it back.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:30 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page