Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-19-2003, 10:58 AM
Registered User
 
Join Date: Mar 2003
Posts: 3
Question Engine light comes when turning on ignition

95 E320: Engine llight comes on only when starting the car (it does not happen every time). I did reset the light several times by disconnecting the battery. One thing is consistent that the light won't come on while driving. Sparks plugs are only two months old. Full tune up was done except distributor caps and spark plugs wires. Any idea?? Thanks.
Reply With Quote
  #2  
Old 08-19-2003, 11:40 AM
Registered User
 
Join Date: Mar 2003
Location: Southern California
Posts: 2,036
"Check engine" and other fault indicator lights should always illuminate when you turn on the ignition. This verifies bulb operation.

Once the engine is started, the fault lights should go out. A couple - ABS and SRS - might take a couple of seconds while the microprocessors go through their start up fault checks.

Duke
Reply With Quote
  #3  
Old 08-19-2003, 12:04 PM
Registered User
 
Join Date: Mar 2003
Posts: 3
Thanks for the response. The light stays on.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 06:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page