Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-24-2003, 06:18 PM
tigeroscar1's Avatar
Registered User
Join Date: Aug 2003
Location: las vegas
Posts: 13
260E with #9 fuze that keeps blowing

I had a problem with the dome light, radio, hazard lights, dash clock not working. I checked the fuze box found the number 9 blown. I replaced it and it blow again. So I unplugged the dome light and everything worked fine. I figured I just needed a new dome light assembly. I replaced it and the samething started to happen again. After doing some seaching in this forum I think I my have a bad power seat diode. My question is which one is it? I think I know wear it maybe located. But I just want to be sure before I start pulling things out.
Another problem I'm having in the my alarm no longer makes a sound if it goes off. The lights flash but the horn does not work. Any thoughts on this?
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 04:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page