Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Closed Thread
LinkBack Thread Tools Display Modes
Old 08-25-2003, 09:18 PM
Registered User
Join Date: Jun 2003
Location: San Francisco
Posts: 20
Mysterious Malfunction

Hello everyone...Having recently driven my 1985 500sel from SF to Pittsburgh, the only problem being a need to replace the Catalytic Converter in Colorado, we've developed a mysterious symptom. Somewhat abruptly, the engine has developed a slight put-put sound, and the initial RPM when starting the engine are very low. The RPM gain momentum to normal, the engine doesn't die. When shifting from D to N the revs increase to 1100r then settle back. The car has had recent plugs, wires, Distributor cap, air cleaner and fuel treatment....any ideas? Thanks, Ken Heimbuch, now of Pittsburgh.
Closed Thread


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 11:39 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page