Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 08-27-2003, 10:43 PM
Registered User
Join Date: Aug 2003
Posts: 6
No oil pressure 450 SLC resolved!!!

When we installed the timing chain cover assembly we forgot to tighten the oil pressure relief valve which connects the main oiling system to the timing chain cover and allows excess oil to return to the oil pan.

I found it in a container, thought it looked awfully like a check valve of some kind, removed the inspection plugs in the front of the timing chain cover and low and behold it fit right in there.

A few rapid turns with my drill and I HAD OIL ALL OVER THE GARAGE!!!

Thanks again for you help.


PS do you have any new pictures of your shop the ones on your web site look like the startup shots?
Reply With Quote
Old 08-28-2003, 04:28 AM
Registered User
Join Date: Sep 2002
Location: Newcastle upon Tyne, UK
Posts: 215
Well done, you'll be a hapy chappy now!

You don't have to start a new thread every time you post. You can reply to your own original message and it keeps it all together. Makes it easier for people to follow what is happening.
Cheers, Neil
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 12:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page