Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-03-2003, 03:11 PM
Registered User
 
Join Date: Sep 2003
Location: Columbia, SC
Posts: 8
check engine light

I just had my crankshaft position sensor replaced on Friday, and yesterday, my check engine light came on again. Any ideas?
1994 S 500
125,000
__________________
Thanks,
REH
Reply With Quote
  #2  
Old 09-03-2003, 04:56 PM
sixto's Avatar
smoke gets in your eyes
 
Join Date: Jun 2000
Location: SF Bay Area
Posts: 19,746
What's the code? Your car should have an LED under the hood. Near the passenger side hinge is a black panel with a 3" diameter cap with a hex fitting on it. Just ahead and inboard of this cap is a raised ~1" cube box with a flip top. With the key in the on position and engine off, press the button for 2 seconds, then count the flashes. Press the button for another 2 seconds and count the next set of flashes. Repeat until you're back to the first set of flashes. The codes will be presented in ascending sequence so when you see the lowest number again, you've read all the codes.

To clear the codes (ONLY AFTER YOU'VE READ ALL THE CODES!), hold the button down for 9 seconds after the code is displayed. You have to clear the codes individually. Then remove the key (for at least 10 seconds?) and start the car. The check engine light should go out and stay out unless something is really wrong or has recurred.

Item 6 at http://pages.prodigy.net/jforgione/MB_S500.html has a lists the fault associated with each code.

Sixto
95 S420
91 300SE
87 300SDL
83 300SD
Reply With Quote
  #3  
Old 09-08-2003, 09:19 AM
Registered User
 
Join Date: Sep 2003
Location: Columbia, SC
Posts: 8
check engine light

Did the test as you recommended (thanks so much that saved me some cash). The code came back to be #26 upshift delay 2 to 3. Is this something serious or something I can wait a while to fix. My cash situation at this time is very limited. Thanks.
__________________
Thanks,
REH
Reply With Quote
  #4  
Old 09-08-2003, 11:41 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Upshift delay codes are nothing to worry about. Odds are its either a vacum leak, bad switchover valve or busted diaphram in the bowden cable.


Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #5  
Old 09-08-2003, 11:46 AM
Registered User
 
Join Date: Sep 2003
Location: Columbia, SC
Posts: 8
check engine light

Is this something serious that needs to be fixed immediately? Any approximations on cost of repair?
Thanks so much.
__________________
Thanks,
REH
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 05:09 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page