Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes-Benz Forum > Mercedes-Benz Tech Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-04-2003, 12:59 AM
OneBadViper's Avatar
0-100, back to 0 in 13Sec
 
Join Date: Feb 2002
Location: Way Down South
Posts: 143
THIS IS STRANGE! HELP....................SRS Problem???

Removed the speedo from the dash on my 96' S420 to replace a light bulb. Now the SRS light in the dash comes on for approx 2 minutes the goes off until the car is turned off and cranked again. What has happened here???
__________________
Porsche's for Breakfast & Ferrari's for Lunch
Reply With Quote
  #2  
Old 09-04-2003, 09:00 AM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
I'll go along with Joe.

The reasoning is that the way your light is operating is one of its warning modes. It will exhibit that activity when it has seen a non airbag related safety issue. It continues to allow the bag operation though probably at a different crash profile.

The typical problem that is not airbag related is the belt buckles and they fail regularly.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #3  
Old 09-04-2003, 09:59 AM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Sounds like a seat belt buckle died.




Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #4  
Old 09-04-2003, 10:52 AM
OneBadViper's Avatar
0-100, back to 0 in 13Sec
 
Join Date: Feb 2002
Location: Way Down South
Posts: 143
Wouldn't the light remain on if the buckle is defective? How can I test the buckle? Does the entire unit get replaced? From the floor to where it latches? Also, why would this just start when working on the dash? Did pulling the cluster have anything to do with it?
__________________
Porsche's for Breakfast & Ferrari's for Lunch
Reply With Quote
  #5  
Old 09-04-2003, 01:52 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
I have this same problem with my R129.

I pulled the cluster out to replace a bulb and cracked the lens.

So I had to disconnect the harnesses to remove the cluster out for the lens replacement.

When I put everything back together, the SRS light became an issue just like OneBadViper...light stays on after system diagnostics, and stays on for a couple of minutes.

I had hoped someone would have an answer to this one...do seat belt switches fail as a result of replacing burnt out cluster bulbs?
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car

Last edited by G-Benz; 09-04-2003 at 01:57 PM.
Reply With Quote
  #6  
Old 09-04-2003, 03:28 PM
it leaks, its german
 
Join Date: Mar 2002
Location: raleigh nc
Posts: 1,111
Nope 140's and 129's just eat the things like tic-tacs. Odds are if tested, it would pass right now, they will see a open condition once and set the code, then it gets buckled, the micro switch frees up and all is well. Except for the code and the fact is no longer has selective firing of the srs system. In this mode it will set off everything at once.



Joe
__________________
Project Smoker, '87 603 powered wagon
Hauler, 96 CTD can you say torque?
Toy 73 Cougar xr7 convertible
Acme Automotive Inc.
Raleigh NC
919-881-0364
Reply With Quote
  #7  
Old 09-04-2003, 05:23 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Ok, since you are the expert, I'll contend it's the seatbelt switch...

...where does this switch reside so I can get it replaced?

I gotta get at least ONE of these cars at 100%...
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #8  
Old 09-05-2003, 01:13 PM
MrCjames's Avatar
California Dreaming
 
Join Date: Jun 2003
Location: SF Bay Area
Posts: 599
SRS mil

Hi all

I thought an extra .02 cents wouldn’t hurt on this topic.

Was the key turned to position 1 or 2 when you had the cluster removed? If so this may have set the SRS mil because the module saw the lamp circuit as open/faulty during the test cycle. Buckles are the most common issue, however, in your case I would be inclined to believe that if the lamp was not on before the bulb replacements than it may have been the above event that set the mil.


I noticed on 92 through 96 SRS systems that :IF: the SRS module recognized a problem with any component, but it was not a current/active fault, the lamp would illuminate for a predetermined time frame than go off. This would remind the driver that something tested faulty during one of the "Self Test" cycles. Should the lamp remain illuminated than it would indicate a fault currently exists and it should be addressed to ensure proper operation of the system. You could consider it a low-grade intermittent fault indicator/detector but since I did not design the system, I can only speculate about this function.

Have a good weekend folks!
Reply With Quote
  #9  
Old 09-07-2003, 12:38 AM
Registered User
 
Join Date: Dec 2002
Location: richmond va
Posts: 2
srs mil

I believe if you check for codes in srs you will find -- mil--
this is a fault in the srs malfunction indicator lamp.
I will bet that the key was in pos 1 or 2 at some time during the
bulb replacement. if you erase the code the problem should go away.
Reply With Quote
  #10  
Old 09-08-2003, 12:45 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
How does one erase codes (for the R129)....is it specified in the owner's manual?

Would love to see this anomaly go away!
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #11  
Old 09-10-2003, 04:59 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Quote:
Originally posted by G-Benz
How does one erase codes (for the R129)....is it specified in the owner's manual?

Would love to see this anomaly go away!
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car
Reply With Quote
  #12  
Old 09-10-2003, 05:35 PM
Moderator
 
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Depends on the year. Up to 94 most systems can be reset using the impulse method. After 94 it takes a dedicated scanner.
__________________
Steve Brotherton
Continental Imports
Gainesville FL
Bosch Master, ASE Master, L1
33 years MB technician
Reply With Quote
  #13  
Old 09-10-2003, 07:56 PM
G-Benz's Avatar
Razorback Soccer Dad
 
Join Date: Apr 2001
Location: Dallas/Fort-Worth
Posts: 5,711
Quote:
Originally posted by stevebfl
Depends on the year. Up to 94 most systems can be reset using the impulse method. After 94 it takes a dedicated scanner.
Thanks Steve!

Great...according to my sig, it's a visit to a technician!
__________________
2009 ML350 (106K) - Family vehicle
2001 CLK430 Cabriolet (80K) - Wife's car
2005 BMW 645CI (138K) - My daily driver
2016 Mustang (32K) - Daughter's car

Last edited by G-Benz; 09-10-2003 at 08:01 PM.
Reply With Quote
  #14  
Old 09-14-2003, 02:13 AM
OneBadViper's Avatar
0-100, back to 0 in 13Sec
 
Join Date: Feb 2002
Location: Way Down South
Posts: 143
Was the key turned to position 1 or 2 when you had the cluster removed?

The key WAS turned on during sometime of the cluster removal. Engine never cranked, but key turned on. Is this my problem? If so, what next? Will I have to have it reset? If so, how much does a Tech usually charge for this?
__________________
Porsche's for Breakfast & Ferrari's for Lunch
Reply With Quote
  #15  
Old 11-08-2003, 07:30 PM
nhodges's Avatar
Registered User
 
Join Date: Nov 2001
Location: Northern VA
Posts: 461
SRS fault

What was the final answer? I have a problem where my SRS light Blinks off and comes back on and remains on for 3-5 minutes before it finally goes out.
__________________
N. Hodges
1994 S350
1987 300 SDL (for sale)

Last edited by nhodges; 11-08-2003 at 07:43 PM.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 08:01 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page