Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-16-2003, 12:47 PM
Registered User
Join Date: Feb 2003
Posts: 6
Climate Control Question

My '95 SL's blower motor will only run on the lowest two speeds. It doesn't matter if the system is set on auto or if the blower speeds are manually selected. The system still blows cold air on a/c and everything else seems to function properly. Is this a controller unit problem or a blower motor issue?
Reply With Quote
Old 09-16-2003, 01:37 PM
dtf dtf is offline
Registered User
Join Date: Jul 2003
Location: South East CT
Posts: 797
Don't know on MBs but that is usually a sign that the blower resistor is shot in an american of Japanese car.
1994 E320 Wagon (Died @ 308,669 miles)
1995 E300 Diesel (194,000)
1999 E300 Turbodiesel (244,000 miles, dies at 255,000)
2006 Toyota Tundra SR5 AC 4X4 (115,000 miles)
2011 Audi A4 Avant (129,000 miles) hate this car!
BMW 330 xi 6 speed manual (100,034 miles)
Reply With Quote
Old 09-17-2003, 06:15 AM
Registered User
Join Date: Dec 2002
Location: Fairfax, VA
Posts: 520
Where is the location of this resistor?
Reply With Quote
Old 09-17-2003, 03:43 PM
Registered User
Join Date: Feb 2003
Posts: 6
I don't think my SL is equipped with a traditional style blower resistor. Vehicles with electro/mechanical controls usually are, but I'm pretty sure mine is microprocessor controlled. That leads me to believe that the problem is probably in the climate control unit itself.

I'd sure like to hear from someone who knows for sure. It would save me a lot of diagnostic time and money.

I really appreciate the input, however.
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 05:51 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page