Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-22-2003, 11:18 AM
Posts: n/a
Defrost cold on one side hot on the other

The weather finally got cool enough to use my defroster on my 1980 300D. At 80C temp the defrost seems to blow warm on the passenger outlets and cool on the drivers side. Is there any obvious reason. The same happens when I switch to bi-level on the floor ducts.

thanks for any help,
Reply With Quote
Old 09-22-2003, 12:46 PM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
Most likely the climate control servo isn't allowing enough water to flow thru the heater code.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 09-22-2003, 02:10 PM
Posts: n/a
What does this mean? Do I need to think about a new servo? Is there any way to test it? Is it going to heat efficiently if I don't do something?

Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 10:36 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page