PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   SL 320 warning light reset? (http://www.peachparts.com/shopforum/tech-help/75634-sl-320-warning-light-reset.html)

rbenz 09-24-2003 12:44 AM

SL 320 warning light reset?
 
I have a 1997 SL 320 and my "red" warning lights on the console came on for the top and roll bar. I replaced the battery and the lights are still on - won't go off. How in the world do you get those lights to reset??? The top is down so even if I raise it manually it won't lock in the rear, just like the manual says. It really is frustrating and I would really appreciate any help.

thanks, Rick

joe p 09-24-2003 08:44 AM

Raise the roll bar fully then lower it fully with the switch in the woodgrain.



Joe

rbenz 09-24-2003 09:29 PM

SL320 red lights
 
Joe,
I will give it shot. Is there a trick to popping up the roll bar?

thanks, Rick

Gilly 09-24-2003 10:06 PM

Welcome, Rick;)

Gilly

Gilly 09-24-2003 10:07 PM

Rick
Just push the top half of the rollbar switch and it should raise (key on or engine running of course)

Gilly

rbenz 09-24-2003 11:02 PM

Gilly,
The top and the roll bar are both inoperable due to the red lights being on. I was able to manually raise the top ( opened up cover with the wrench ) but I could not get the roll bar up. It's like it's locked down. Now that I think about it, I should have said that the Top and Rollbar were not "functioning" from the beginning. They quit working when lights came on. The car was in the garage for about 2 months and when I tried to start it the battery failed. That's when the fun began.

thanks again
Rick

Gilly 09-24-2003 11:56 PM

OK Rick, got it.

First, you could also start this same thread over in the "tech help" forum, you may also get some responses there.

What I am leaning towards is this, and I know it won't make a ton of sense, OK?

Sometimes I've seen this happen, and what MB advised me to do it totally disconnect the control module for the soft top and windows. This is one module (does both jobs) and is located behind the passengers seat, inside that storage compartment under the false floor. You need to remove 3 10mm plastic nuts to remove the false floor, then you'll see the rather large metal control unit, it is I believe equipped with 3 electrical connectors, hopefully you know how to remove these connectors, has like a sliding latch on all 3 of them. Usually you need to remove the nuts that hold it to the floor to release all off the connectors (it's a tight fit, you'll see). Don't turn the key on while doing this, keep it off until you're done. Just disconnect all the electrical connectors, plug them all back in, bolt it down, then try it.

Before doing this, can you tell me if the "express down" feature of the windows is working OK? If not, I would give synchronizing the side windows one more shot.

Let me know how it's going.

Gilly

rbenz 09-26-2003 03:00 PM

SL302 top and roll bar lights
 
Gilly,
I pulled the false floor out on the passenger side and unplugged three wires from a "round" module. I'm not sure if that is the correct item or not? There is a large metallic box that has a good sized power cord going into it. I didn't do anything with it for fear that I might create more chaos. After pulling the 3 small wire off and plugging them back in, I still had the same problems. The windows do work on "express" but the top and roll bar will still not operate nor will the red lights go out. Thanks for the input...I guess I'l have to bit the bullet and take it to the shop! $$$$ OUCH $$$$

thanks again, Rick

rbenz 09-26-2003 03:08 PM

SL302 top and roll bar lights
 
Gilly,
I pulled the false floor out on the passenger side and unplugged three wires from a "round" module. I'm not sure if that is the correct item or not? There is a large metallic box that has a good sized power cord going into it. I didn't do anything with it for fear that I might create more chaos. After pulling the 3 small wire off and plugging them back in, I still had the same problems. The windows do work on "express" but the top and roll bar will still not operate nor will the red lights go out. Thanks for the input...I guess I'l have to bit the bullet and take it to the shop! $$$$ OUCH $$$$

thanks again, Rick

Gilly 09-26-2003 05:52 PM

It's not round at all, it's about the shape of a carton of cigarettes, maybe not quite as long. Held down by 3 10mm nuts. Has 2 or 3 large wiring connectors, not just single "wires".

Gilly

rbenz 09-30-2003 02:13 PM

SL320 top and roll bar lights
 
Gilly,
Well I finally got to the bottom of it. It was the control unit ( N-52 ) for the top. I tried everything but was not having any success so I talked a friend of mine into bringing his '98 SL500 over and we swapped the control units...That was it. His worked fine on my car - all functions - and then I tried mine on his car and it did the same thing as it did on my car. FINALLY!
Do you know if these can be rebuilt or purchased somewhere with a better price than the local MB dealer?
I really want to thank you for your advice.
Rick

Gilly 09-30-2003 08:02 PM

You could try Potaomac German Auto to try to find a used one. Not sure if you'd find a reman unit for these.
Also email Phil at Fastlane and see what kind of a deal you can get on a new one from him.

Gilly


All times are GMT -4. The time now is 05:28 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website