Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-25-2003, 08:14 PM
SPIKES's Avatar
Registered User
 
Join Date: Apr 2003
Location: CORAL SPRINGS FL
Posts: 101
operating temp w210?

my 97 e320 is running at about 95-100 degree temp range in slow travel with outside temp about 80 degrees.

it does not go higher.....
is it running too hot?
changed coolant and made no difference.

any suggestions please.
Reply With Quote
  #2  
Old 09-26-2003, 08:54 AM
SPIKES's Avatar
Registered User
 
Join Date: Apr 2003
Location: CORAL SPRINGS FL
Posts: 101
THANK YOU.
i am looking at the a/c unit and it runs 96-100 degrees but no more.

i am sure it is normal. on the guage it is under the 3/4 mark (100 degrees) between 80 and 120.

thanks for your reply.
glad to see some response on this board.
Reply With Quote
  #3  
Old 09-26-2003, 11:17 AM
blackmercedes's Avatar
Just a guy
 
Join Date: Dec 2000
Location: St. Albert, Alberta, Canada
Posts: 3,492
In warm/hot weather with the AC blowing hard, my C230 reaches 98-101C. The E300 did the same thing.
__________________
John Shellenberg
1998 C230 "Black Betty" 240K

http://img31.exs.cx/img31/4050/tophat6.gif
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 02:39 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page