Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-27-2003, 11:53 PM
Join Date: Mar 2000
Posts: 37
Red face ASR problem on a 1991 560SEL

Helllo all, just bought an 1991 560SEL, with only 50.000 miles everything is fine but!! as soon as you start the engine all the lights go off. as soon as you touch the gas the ASR light comes on, but the unit out on the engine is still working ok the engine speeds up and seems to drive fine.. anyone know where i should look to find the little problem

Thanks Rob...
Reply With Quote
Old 09-28-2003, 08:19 AM
Registered User
Join Date: Jun 2001
Location: Omaha, NE
Posts: 962
Have you done a search yet? If not, search on "asr light" and you will see how to diagnose the system. In short, you will need to pull the error codes to track this down. Could be anything from a faulty brake light switch, if you're lucky, to a bad throttle actuator, if you're not.
'93 400E
Reply With Quote
Old 09-29-2003, 08:11 AM
Join Date: Mar 1999
Location: Tucker, Ga USA
Posts: 12,153
The 1991 cars with ASR don't have ANY code memory or retrieval ability at all.
You will need to find a dealer that has a break-out box for that system to diagnose your problem.

Most likely is the throttle potentiometer at the back of the intake manifold.
MERCEDES Benz Master Guild Technician (6 TIMES)
ASE Master Technician
Mercedes Benz Star Technician (2 times)
44 years foreign automotive repair
27 Years M.B. Shop foreman (dealer)
MB technical information Specialist (15 years)
190E 2.3 16V ITS SCCA race car (sold)
1986 190E 2.3 16V 2.5 (sold)
Retired Moderator
Reply With Quote
Old 09-29-2003, 09:41 AM
Join Date: Mar 2000
Posts: 37

Thanks so much for the info

Reply With Quote
Old 09-30-2003, 08:52 PM
Join Date: Mar 2000
Posts: 37
asr problem

yep it was the unit on the back of the intake manifold. "throttle potentiometer" i took it apart and it had been full of water at some point all rusty inside. .. boy that thing is expensive Thanks for the help!!!
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 02:53 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page