Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 09-29-2003, 10:29 PM
Posts: n/a

Wassup people...over here from 190Revolution. I've got a 1988 190e 2.3 8V. Gotta problem if anyone can help. I installed some white face gauges a while ago. Ever since then, my SRS light stays constantly on and also none of my interior auxilary lighting the window switches don't light up any more, the stock radio/cassette doesn't light up, the AC Buttons or the little green light next to the ignition. Any ideas what could be wrong? Thanks for all the help...and PS, ITS NOT A FUSE!!!! I've checked that several times.
Reply With Quote
Old 09-29-2003, 10:41 PM
Benz300's Avatar
Benz Enthusiast
Join Date: Sep 2003
Posts: 786
I would double check all the connections in the back of the cluster since i'm assuming you had to take the cluster out to change the needles' color etc.
Whether you think you can or cannot, Either way you're right!. by Henry Ford.
Reply With Quote
Old 09-30-2003, 03:16 PM
Posts: n/a
Everything's plugged in...checked today....anyone know which wire it would be for either the SRS or the auxilary lighting???
Reply With Quote
Old 09-30-2003, 05:51 PM
Registered User
Join Date: Sep 2003
Posts: 40
hey dude. I have the same problem..but it was from when I installed my stereo.. I dunno wtf is up!!

for the SRS light. check under the seats and make sure those little plugs are connected on both of them.. moving ur seat to far back or someting might have unplugged one.. that happend to me.. and my SRS light came on...

ask chuni on 190rev what he did to get his lights working again..he said he just rewired one wire to another 12v power source.. still tho.. I wonder why our lights are going out like this
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

All times are GMT -4. The time now is 09:07 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page