PeachParts Mercedes-Benz Forum

PeachParts Mercedes-Benz Forum (http://www.peachparts.com/shopforum/)
-   Tech Help (http://www.peachparts.com/shopforum/tech-help/)
-   -   Smokin' '76 240D (http://www.peachparts.com/shopforum/tech-help/7625-smokin-76-240d.html)

tnt5 05-19-2000 06:27 PM

Hello,

I have a 76' 240D with manual trans. and 340k miles. I just bought the car from a one-owner that kept meticulous documentation. The car smokes (blue/sometimes grey)excessively when at idle or between shifts. It also smokes heavily and surges wildly on deceleration while in gear. All I was told by a local tech was "overhaul". I read TXBills' articles on fuel adjustment for his 300D but my problem seems a little different his. I really like the car and wish to keep it because asthetically, it's in great shape! I noticed that Benzmac resides just below me....any help for this newbie??

Thanks,

Todd -

stevebfl 05-19-2000 07:27 PM

You car has a pneumatic governor and it probably has a ruptured diaphram.

To test remove the red air filter from the rear of the pump. Place your thumb over the opening while the engine is idling. If the engine speed is affected by this then the diaphram is bad. The reasoning here is the diaphram passes air which comes through the vent in the air filter. When you put your finger over the hole (sealing it of course)you remove this extra air which is passing through the diaphram. The diaphrams aren't too expensive and are a little tricky to replace but can be done by an experienced tech in less than an hour I'd say if there are no frozen bolts.

------------------
Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician

tnt5 05-19-2000 10:11 PM

Thanks for the fast response Steve. I'll certainly give that a try and get back here very soon with the results.

Todd

[This message has been edited by Webmaster (edited 05-20-2000).]

tnt5 05-20-2000 01:59 PM

After a small search for the red filter located on the injector pump it was removed as you decribed. After placing my thumb over the opening while at idle, the rpm increased probably an extra 200-300. Was this the change you were looking for?

Thanks again Steve for the fast help and saving a ton of unecessary work.

Todd

stevebfl 05-20-2000 03:19 PM

Not exactly, but if you get any change then there is a problem. Normally the action causes the engine to go slower, but you are affecting two separate activities. One is the extra air that is going into the motor. Blocking this should reduce engine speed. The other activity is the actual mixture creation. Having a hole in the diaphram causes the mixture to be so rich the engines speed is affected. Blocking the hole can improve the mixture and thus change the idle either way.

In any case a good diaphram will see no change when doing the test. Replace the diaphram.

------------------
Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician

tnt5 05-20-2000 03:30 PM

Will do......

This might take a few days to achieve. After the diaphram is replaced, I will again post the results.

Todd

tnt5 05-22-2000 05:10 PM

Made the appointment today....The tech will have the diaphram replaced on Wednesday for $130 out the door. Thanks again for the help, Steve....look for a resulting post Wednesday evening.

Todd

tnt5 05-25-2000 09:32 AM

AND THE RESULTS:

Sorry for the late response.....slow getting in last night.

The relpacement diaphram repair charge ended up being $120.86.....BELOW estimate....always like a good surprise there. On the repair, however, we batted 50%. The wild surging and jerking on decerleration are gone but the smokin' 240D is still a smokin' 240D. You were right. That diaphram repair did, in fact, need to be replaced.

Now about that smoke.....How does one get rid of the blue/grey beast on idle or deceleration while in gear? Rather embarassing when people pull up behind you at a stoplight then back off 20 feet. LOL!

As a liner note for Steve:

When I conducted that filter cap test the other day, I failed to mention that the car was not at running temp. It was idling just after a start.....maybe the answer to why the r's went up instead of down?? The idle speed is considerably higher when warm. Thoughts?

Thanks,

Todd



All times are GMT -4. The time now is 06:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2018 Pelican Parts, LLC - Posts may be archived for display on the Peach Parts or Pelican Parts Website