Parts Catalog Accessories Catalog How To Articles Tech Forums
Call Pelican Parts at 888-280-7799
Shopping Cart Cart | Project List | Order Status | Help




Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-02-2003, 11:30 AM
Registered User
 
Join Date: Sep 2003
Location: Oxford UK
Posts: 7
SEL 600 oil pressure problem

Hi,
When I bought my 600 it was showing no oil pressure at the dash guage and occasional red light. I was told by the owner it was the pressure switch.
I have just changed this only to find that upon starting the guage flickers then back to as it was with no reading and occasional red light.
The engine runs and sounds fine so I assume there is pressure..................Help.

Dave.
__________________
Mad Englishman who like a challenge
Reply With Quote
  #2  
Old 10-02-2003, 11:40 AM
MrCjames's Avatar
California Dreaming
 
Join Date: Jun 2003
Location: SF Bay Area
Posts: 599
Best not to assume on that engine, put a gauge on it and confirm it is good. Than you can begin pinpointing where the problem lies.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -4. The time now is 10:35 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page