Parts Catalog Accessories Catalog Tech Info Tech Forums
  Search our site:    
 Cart  | Project List | Order Status | Help    

Go Back   PeachParts Mercedes ShopForum > Technical Information and Support > Tech Help

LinkBack Thread Tools Display Modes
Old 05-25-2000, 03:32 PM
Posts: n/a
I have an 87 190e 2.3, the AC has started working intermittently - not due to low freon though. It was working in the morning on the way to work, and it stopped. It doesn't operate at all today. Any suggestions on testing, where to check for current/ voltage/ continuity would greatly be appreciated.
Reply With Quote
Old 05-25-2000, 03:36 PM
Posts: n/a
Start with the serpentine belt and/or the belt tensioner. My '88 did the same thing. If the belt is too loose or the tensioner is shot, the compressor pulley will slip enough to trip a speed sensor, and the A/C won't run.
Reply With Quote
Old 05-25-2000, 06:19 PM
Join Date: Mar 2000
Location: Gainesville FL
Posts: 6,844
Since you are loosing the compressor as a symtem you must decide whether the problem is an inside control problem (pushbutton controller et al) or a compressor relay problem under the hood. The way to tell is at the low/high pressure switch on the drier. The pushbutton controller tells the compressor controller to work by grounding the signal coming fronm the compressor controller. If both terminals are battery voltage (at the low pressure switch) the inside system is at fault. If the two signals are low near 0v probably just less than 1v then the compressor controller system is being switched but is inactive for an under the hood problem.

The common problem on your year 190 for a pushbutton control problem is: the lack of full movement or improper voltage from the mode door potentiometer. As the door closes the voltage drops (I think...I have to look it up every time). If it doesn't move all the way or if the potentiometer is out of adjustment the compressor on signal is never given. 190s also had a fair share of evaporator sensor problems.

The under hood problems with the compressor controller are usually related to the belt protection system which matches engine speed to compressor speed. The usual problem is bouncing belts or slightly slipping clutches (watch for oiled down clutch).

Steve Brotherton
Owner 24 bay BSC
Bosch Master, ASE master L1
26 years MB technician
Reply With Quote


Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

Similar Threads
Thread Thread Starter Forum Replies Last Post
Heater A/C fan inop in certain temp range yositimy Tech Help 1 05-15-2002 09:49 PM
A/C 86 190E 201.024 M Reinwald Tech Help 1 08-16-2000 09:25 PM
replacing an a/c compressor '89 190E 2.6 bradfordro Tech Help 1 06-12-1999 07:13 PM
Problem still with a/c in '85 190E Steve190E 2.3 Tech Help 1 06-08-1999 06:34 PM

All times are GMT -4. The time now is 04:59 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2016, vBulletin Solutions, Inc.
Search Engine Optimization by vBSEO 3.6.0
Copyright 2011 Pelican Parts - Posts may be archived for display on the Peach Parts or Pelican Parts Website -    DMCA Registered Agent Contact Page